ubuntu16.04 wordpress

配置问题

使用ubuntu16.04,发现php5不怎么能用~网页打开直接是php文件内容,没有解析php文件,查看后发现:

  1. ubuntu16.04已经选择PHP7.0作为新的基础包了,所以不能在Ubuntu16.04上安装PHP5,如果硬要安装,则会出现依赖问题,而且一般无法解决:
  2. 比如,Ubuntu16.04上的软件需要的是一个较高版本的库,而PHP5需要的是一个较低版本的库,系统会提示:libapache2-mod-php5依赖于某某库,但该库不能被安装。因为php5基于较低版本的库文件,如果安装的话又有其他软件将不能运行;
  3. 故,推荐安装PHP7.0,并且用“libapache2-mod-php”代替“libapache2-mod-php5”。

Continue reading “ubuntu16.04 wordpress”